Bloqué

Alors voilà, je suis donc coincé depuis hier matin, et semble-t-il suite à une “simple” mise à jour de sécurité du Mac. Toujours sous Sierra (10.12, donc), je n’ai plus moyen de lancer sass ou compass. C’est ballot.

Je parcours donc les interwebs pour tenter de trouver une solution à mon problème. Beaucoup de posts sont liés à la mise à jour High Sierra, ce qui n’est donc pas mon cas. D’autres avec Mojave, car à chaque mise à jour d’OS (chaque année, c’est tellement super utile) son lot d’emmerdes.
J’ai bien des messages d’erreurs, des trucs et des bidules que je comprends plus ou moins, mais ça ne me dit pas trop ce que je dois entreprendre pour que ça retombe en marche. J’ai testé déjà plein de solutions qui fonctionnaient pour les autres, mais non.

Aujourd’hui on a répété pour samedi (on en recause), du coup ça ne m’a pas gêné - juste occupé inutilement l’esprit - mais il faut que je trouve une solution pour demain. Grompf.


Edit du 9/11 à environ 00:50 : après moults autres tentatives et une certaine ténacité[1], j’ai fini par réinstaller une version plus ancienne de Ruby avec rvm suite à la lecture de ce ticket sur Github, puis compass. C’est un “workaround” pas franchement satisfaisant mais qui a la bonne idée de refaire tourner sass & compass. Je me pencherai à nouveau dessus pour une installation plus clean quand j’aurai un peu de temps.

Note

[1] Qui a dit entêtement ?

Ajouter un commentaire

Les commentaires peuvent être formatés en utilisant la syntaxe Markdown.

Ajouter un rétrolien

URL de rétrolien : https://www.envisagerlinfinir.net/trackback/2937

Haut de page